Backup and Restore a Patient Database

Table of Contents:


Summary

Backing up your patient database is an important task that should be done at least weekly. MyoVision Technical Support recommends saving a copy of your backups to an external source such as a USB thumb drive or an external hard drive. These processes also make it easier to share patient records with another user with MyoVision software installed. This is also the best way to transfer your database from one computer to another.

IMPORTANT REMINDER: Depending upon country, state, or local laws you may be required to get patient consent prior to sharing or sending their data. Please abide by these laws.

It's recommended that standard computer users use Method 1 to backup and restore data. Method 2 is intended for advanced computer users.



Method 1:

In this method we will use the "Backup" and "Restore" tools inside the MyoVision software to backup and restore your database.

Backup Your Patient Database MyoVision Software

Click on the buttons inside the tabbed menu to see the different ways to backup your MyoVision data:

Method 1: Inside the Software

Use this method to create a copy of your MyoVision database using the built-in backup feature.

  1. To begin making a backup select File then Backup Exams.
  2. Inside of the Window that opens select: (1) Where you want to save your backup to (2) The File Name you want to give to your backup file, (3) Click Save to create the backup. 
  3. If you get the following message after selecting Save then your backup was successful.

Method 1: Backup Inside the Software





Restore Your Patient Database Using the MyoVision Software

Click on the buttons inside the tabbed menu for instructions on how to restore a database:

Method 1: Inside the Software

**Only use this method if you used Method 1 when backing up your data.** This method uses the built-in process for restoring a patient database. 

  1. Open the MyoVision software then open the File menu, select the Restore Exams option.
  2. A warning will pop-up letting you know that restoring a backup will erase your current database and replace it with the database inside of the backup. Click OK to continue.
  3. In the window that opens, navigate to the location where the backup is saved. Select the backup file then click Open.
  4. Another warning prompt will pop-up, letting you know that by restoring this backup you will be erasing all of the exams currently in your database. Click OK to continue.
  5. You will then receive a prompt on whether or not the restore was successful.
  6. Open an exam to verify that you're database has been restored.

Restoring a Daily Backup File

**Only use this method if you are restoring a Daily Backup file created by the MyoVision software.** 

  1. Open the MyoVision software then open the File menu, select the Restore Exams option.
  2. A warning will pop-up letting you know that restoring a backup will erase your current database and replace it with the database inside of the backup. Click OK to continue.
  3. In the window that opens, navigate to the location where the backup is saved.  Click the Files of type drop-down menu and select All Files. Select the daily backup file (will end in .bu) then click Open.
  4. Another warning prompt will pop-up, letting you know that by restoring this backup you will be erasing all of the exams currently in your database. Click OK to continue.
  5. You will then receive a prompt on whether or not the restore was successful.
  6. Open an exam to verify that you're database has been restored.

Method 1: Inside the Software




Method 2:

This method is intended for advanced computer users. This method will take you through the process of backing up the raw database file (the raw file that SQL Server saves your data in). After a raw database file has been imported onto the new computer you will need to "Attach" the raw database file to your software.

Backup Your Raw Database Files

Click the tabbed menu to view the instructions:

Method 2: Copy Raw Database

Use this method to save a copy of the raw SQL database files for your patient database.

  1. Open File Explorer and Navigate to:
    C:\\ProgramFiles(x86)\Microsoft SQL Server\MSSQL{NAME OF YOUR SQL SERVER}\MSSQL\DATA
  2. Inside this folder while holding the CTRL key on the keyboard down, left-click the MyoVision and MyoVision_log files to select them. Once both files are selected, right-click and choose Copy.
  3. Now, navigate to where you want to save the copies of your raw data files. Then, right-click and choose Paste.

Method 2: Copy Raw Data Files






Restore Your Raw Database Files

Click on the buttons inside the tabbed menu for instructions on how to restore a database:

Method 2: Paste Raw Database Files

**Only use this method if you used Method 2 to backup your data** These instructions will show you how to restore a copy of the raw MyoVision database files. 

  1. Make sure that you've followed all the steps in Backup Method 2: Copy Raw Data File, and have copied a raw database file.

  2. Navigate to C:\\ProgramFiles(x86)\Microsoft SQL Server\MSSQL12.{NAME OF YOUR SQL SERVER}\MSSQL\DATA in file explorer.
    Right-click and select Paste.

  3. Once the MyoVision and MyoVision_log files have been pasted into the SQL Service folder the MyoVision software will restores to the database saved in the raw data file.

Method 2: Paste Raw Database Files



Automatic Daily Backups

The MyoVision software makes a Daily Backup the first time it's opened every day. This portion of the guide will show you how to locate and make copies of the automatic Daily Backup files, created by the software:

  1. Open the file explorer for your computer. Click the View tab in the top toolbar. Make sure the Hidden Items box is checked.

  2. Navigate to C:\Users\{Your User Name}\AppData\Local\Precision Biometrics Inc\MVSW\DailyBackups\.
    Inside this folder you will find the copies of your daily backup files.


  3. From here left-click on the file with the corresponding day and date that you would like to make a copy of.
    The date modified column will tell you when the back up was created.

  4. Right-click the file and select copy.

  5. Inside of the file explorer go to where you want to save the copy. Then, right-click and select Paste. Once the copy has been saved to the new location you are complete.