How Do I Transfer My MyoVision Database to a New Computer?

Summary

This article will take you through the process of transferring your MyoVision Database to a different computer.

**Before you continue with this article, make an additional backup file of your patient database and save it to an external source. Click Here to learn how to save a backup file of your patient database to an external source. This is done to help prevent any data from being lost in the transfer. **


Table of Contents

  1. Backup Your Old MyoVision Data and Copy Your Registration Key
  2. Install and Setup MyoVision on the New Computer
  3. Restore MyoVision Data
  4. Transfer the Raw Data Files (Advanced Users)

1. Backup Your Data and Copy Your Registration Key

Back up your data on your old computer and locate your Registration Key. For this step you will need a flash drive or USB stick.

  1. Plug the USB stick or flash drive into your old computer.
     
  2. Open up the File menu and select "Backup Exams" 
  3. Select your flash drive/USB stick from the drop-down menu. Enter the "File name" you want your backup file to be. Click "Save." 

Now that the backup data has been saved to the USB stick, the next step is to copy/write down your Registration Key. If you do not have a Registration Key activated in your software, you can purchase one today from our store site.

  1. Open the "Help" menu and select "Registration" 
  2. Write down your Registration Key or copy and paste it in an email to yourself. This way have quick access to it on the new computer.




2. Install and Setup MyoVision Software on the New Computer

First, your will need to have the MyoVision software installed on the new computer.

Step 1: Download Installer


The first step is to download the installation file. The install file is called MVSW_ATLAS_S.exe and is used to install or update MyoVision.

  1. Go to myovision.com/download.html then select Download Now. The first time that you download a new version of the software you will receive a 30-Day Free Trial. After that you will need a valid Registration Key to keep using all of the newest software features.  
    Stop worrying about getting all of the newest software releases and features by signing up for our Annual Software Subscription. Click the link Here to start your subscription today! 
  2. You will be prompted on whether you would like to run or save the program. For the best results you will want to save the installer instead of running it directly from the MyoVision website.
  3. Once the file has finished downloading move on to Step 2: Install Software.

Step 2: Install Software


In this step we're going to run the file that we downloaded in Step 1. This will get MyoVision installed or updated on your computer.

  1. When the installer starts, you will want to click Next > at the first screen to begin the installation.

  2. Continue running the installer until the following Window appears. Then, select the option that best matches the type of installation you are performing.

  3. The Installer will let you know once it's successful. Once the installer is done click the Finish button to complete the installation.

  4. The Installer fails or gets an error, check your computer for updates. Once all the updates are installed, restart your computer and try running the installer again.

Download and Install Your Software


3. Restore MyoVision Data

Now that the software is installed, the next step is to restore your data and register the software. If the computer has already been used to scan patients or already has patient data in the database Click Here to learn how to merge the two databases.

  1. Connect the USB stick or flash drive, that the database backup file was stored on, into the new computer.
     
  2. Open the "File" menu and select "Restore Exams" 
  3. A warning will pop up. Click "OK" 
  4. Select the USB stick from the drop-down menu, select your restore file and click "Open" 
  5. When the warning pops up click "OK"When the data is done restoring, the following message will appear: 
  6. Open the "Help" menu and select "Registration" 
  7. Enter your Registration Key into the boxes shown and click "Activate"

After the software has been activated you will want to close and re-open it for the activation to complete.


4. Transfer the Raw Data Files

You can also transfer the raw database files to the new computer via a flash drive or USB stick. It's recommended that this method be used by Advanced PC Users only.

  1. Open File Explorer. Navigate to "ProgamFiles(x86)". Then open the "Microsoft SQL Server" folder. Inside this folder you should see either a folder named "10.5.SQLEXPRESS" or "12.PBI_MYOVISION". If neither of these folders are there, you may need to check the "Microsoft SQL Server" folder inside the "ProgramFiles" folder instead of "ProgramFilesx86".
     
  2. Open the "10.5.SQLEXPRESS" or "12.PBI_MYOVISION" folder. Open the "MSSQL" folder and the "DATA" folder. Locate the "myovision.mdf" and the "myovision_log.ldf" files. Hold down the "Control" key on the keyboard and select both files. At this point you will want to copy these two files to your flash drive or USB stick. 
  3. On the new computer you will want to open File Explorer. Navigate to the C drive and open "ProgramFilesx86" or "ProgramFiles," depending on whether the computer is 32-bit or 64-bit. Open the "MSSQL12.PBI_MYOVISION" folder. Open the "MSSQL" folder. Open the "DATA" folder. Save the copies of the raw data files ("myovision.mdf" and the "myovision_log.ldf" files) into this "DATA" folder.
     
  4. Open the MyoVision software on the computer. Open the "Setup" menu and select "Database". Click the "<<Advanced" button.Click the "Attach" button.
     
  5. An Alert will pop up. Select "Yes" to continue. Locate the folder that you saved the "myovision.mdf" and the "myovision_log.ldf" files in Step 3. Select the "myovision.mdf" file and click "Open".
     
  6. The software should tell you the data file has been connected to the software.